Melon (MLN) Funding Delays
Incident Report for Kraken
Resolved
Melon (MLN) deposits and withdrawals have been processed. We will continue to monitor the situation.
Posted 3 months ago. Nov 15, 2018 - 14:13 UTC
Investigating
We are currently experiencing delays with Melon (MLN) funding. We are working to resolve the issue and will update as soon as we have further information.
Posted 3 months ago. Nov 15, 2018 - 10:54 UTC
This incident affected: Digital Currency Funding (Melon (MLN)).