Connection Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 13, 2017 - 23:03 UTC
Update
Connection issues resolved, and website access is restored. Trading issues may persist when volume is high.
Posted Nov 13, 2017 - 23:03 UTC
Investigating
We are getting widespread reports that access to the website is either unavailable or unreliable. We are investigating and working to restore access.
Posted Nov 13, 2017 - 18:34 UTC