Ethereum (ETH) Deposit and Withdrawal Delays
Incident Report for Kraken
Resolved
Ethereum (ETH) deposit/withdrawal times have returned to normal.
Posted Sep 19, 2018 - 15:43 UTC
Investigating
We are currently experiencing delays with deposits and withdrawals for Ethereum (ETH). We are working to resolve the issue and we will update as soon as we have further information.
Posted Sep 19, 2018 - 15:34 UTC
This incident affected: Digital Currency Funding (Ethereum (ETH)).