Litecoin LTC Funding Gateway Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 10:17 UTC
Investigating
We are currently experiencing delays processing deposits and withdrawals for Litecoin (LTC). Our engineers are aware of the issue and are currently investigating it.
Posted Aug 26, 2020 - 10:13 UTC
This incident affected: Digital Currency Funding (Litecoin (LTC)).