Tether USD - OMNI Withdrawal delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 01:47 UTC
Investigating
We're investigating an issue with the Tether USD - OMNI funding gateway. Withdrawals are currently delayed, deposits are fully operational. We are working to resolve the issue and we will provide any updates as soon as possible
Posted Oct 29, 2020 - 00:36 UTC