Domestic US Dollar (USD) Deposit Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 08:25 UTC
Investigating
We've received increasing requests regarding missing domestic US Dollar (USD) deposits between Monday, April 20 and Wednesday, April 22. We've contacted our wire processor to proactively begin searching for impacted deposits. Please contact support if you have a missing deposit within that timespan. More recent deposits are not affected.
Posted Apr 24, 2020 - 14:11 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic).