Cosmos (ATOM) Funding Delays
Incident Report for Kraken
Resolved
Cosmos (ATOM) Funding has now been restored.
Posted 13 days ago. Oct 05, 2019 - 07:46 UTC
Investigating
We are receiving reports of Cosmos (ATOM) deposits not crediting and withdrawals not being sent out. Our engineers are investigating the issue and will provide any updates as soon as possible.
Posted 13 days ago. Oct 05, 2019 - 06:38 UTC
This incident affected: Digital Currency Funding (Cosmos (ATOM)).