Domestic USD Funding
Incident Report for Kraken
Resolved
Domestic USD funding has now been restored.
Posted Sep 17, 2019 - 16:39 UTC
Investigating
We have identified an issue in the processing of domestic USD deposits and withdrawals. Our engineering team is investigating and working on resolving the issue. We will provide an update as soon as possible.
Posted Sep 17, 2019 - 16:21 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic).