KUSAMA (KSM) Funding Delays
Incident Report for Kraken
Resolved
This Incident has now been resolved
Posted Oct 12, 2021 - 12:27 UTC
Update
We are continuing to investigate the issue
Posted Oct 12, 2021 - 11:50 UTC
Investigating
We're investigating an issue with the KUSAMA (KSM) funding gateway. Withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Oct 12, 2021 - 10:01 UTC
This incident affected: Digital Currency Funding (Kusama (KSM)).