Funding Transactions - Display Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 26, 2020 - 14:55 UTC
Investigating
We are receiving reports of clients not being able to see their latest transactions in the funding tab. We are working to resolve this issue and will update as soon as we have more information.
Posted Nov 26, 2020 - 14:40 UTC
This incident affected: Website.