XLM Funding Delays
Incident Report for Kraken
Resolved
XLM funding has been restored, and transactions initiated during this incident will now be processed.
Posted 30 days ago. Mar 25, 2019 - 23:48 UTC
Investigating
We’re investigating reports of delays in processing XLM deposits and withdrawals. We’ll provide an update as soon as we have any more information to provide.
Posted about 1 month ago. Mar 25, 2019 - 19:58 UTC
This incident affected: Digital Currency Funding (Stellar Lumens (XLM)).