Email Delivery Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 18:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2021 - 19:51 UTC
Identified
We don't have any new information to share at the moment. We'll be back with an update as soon as we do. Thank you for your patience.
Posted Sep 07, 2021 - 16:57 UTC
Investigating
We are continuing to investigate this issue.
Posted Sep 07, 2021 - 15:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2021 - 14:03 UTC
Update
No additional news to share at this stage, but we’re focused on getting things back to normal as quickly as possible. Thanks for bearing with us and we'll continue to keep you updated as we know more.
Posted Sep 07, 2021 - 13:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 07, 2021 - 12:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 07, 2021 - 12:07 UTC
Investigating
We are currently experiencing email delivery issues. We are investigating and are working to resolve them as soon as possible.

Note: If you are experiencing an issue with authorising a new device, please use a device you have previously approved (if possible) to access your account.
Posted Sep 07, 2021 - 11:52 UTC
This incident affected: Website.