EOS (EOS) And Zcash (ZEC) Funding Delays
Incident Report for Kraken
Resolved
Zcash (ZEC) deposits and withdrawals have now been processed.
Posted 4 months ago. Nov 22, 2018 - 04:25 UTC
Update
EOS (EOS) deposits and withdrawals have now been processed. We will continue to monitor the situation.
Posted 4 months ago. Nov 21, 2018 - 18:30 UTC
Investigating
We are currently experiencing delays with EOS (EOS) And Zcash (ZEC) funding. We are working to resolve the issue and will update as soon as we have further information.
Posted 4 months ago. Nov 21, 2018 - 17:25 UTC
This incident affected: Digital Currency Funding (ZCash (ZEC), EOS (EOS)).