Signet Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 15:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2021 - 14:18 UTC
Investigating
Signature Bank is investigating an issue with Signet Funding. Deposits and withdrawals are currently delayed. There's no ETA at the moment, but we will provide any updates as soon as possible.
Posted Dec 22, 2021 - 12:45 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).