Terra (LUNA) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 19, 2021 - 06:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 19, 2021 - 04:56 UTC
Investigating
We're investigating an issue with the Terra (LUNA) funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Dec 19, 2021 - 03:41 UTC
This incident affected: Digital Currency Funding (Terra (LUNA)).