Euro (EUR) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved and funding operations have been fully restored. Deposits and withdrawals are being processed normally. Thank you for your patience.
Posted Mar 13, 2020 - 21:12 UTC
Investigating
We are receiving reports from clients that Euro (EUR) funding operations are slightly delayed. The impact is limited, but it appears to resulting in some processing delays for deposits and withdrawals. Our engineers have identified the issue and are working to resolve it as soon as possible. We will provide updates as necessary.
Posted Mar 13, 2020 - 12:53 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits).