Euro (EUR) - SEPA Funding Delays
Incident Report for Kraken
Resolved
Deposits and withdrawals are being processed normally again. Thank you for your patience.
Posted Mar 16, 2020 - 19:11 UTC
Identified
We are receiving reports from clients that Euro (EUR) - SEPA funding operations are slightly delayed. The impact is limited, but it appears to resulting in some processing delays for deposits and withdrawals. Our engineers have identified the issue and are working to resolve it as soon as possible. We will provide updates as necessary.
Posted Mar 16, 2020 - 12:33 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA).