Fidor Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 07:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 14, 2022 - 07:07 UTC
Monitoring
The issue seems to have resolved and we are currently monitoring the situation.
Posted Jun 14, 2022 - 07:07 UTC
Investigating
We are currently investigating the issue with the Vendor.
Posted Jun 14, 2022 - 04:15 UTC