Tezos (XTZ) Funding Delays
Incident Report for Kraken
Resolved
Tezos (XTZ) funding has been restored. All pending deposits and withdrawals should now have been processed.
Posted 4 months ago. Nov 27, 2018 - 14:30 UTC
Investigating
We are currently experiencing issues with Tezos (XTZ) funding. We are working to resolve the issue and will update as soon as we have further information.
Posted 4 months ago. Nov 27, 2018 - 13:14 UTC
This incident affected: Digital Currency Funding (Tezos (XTZ)).