Email Delivery Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 12:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2020 - 11:56 UTC
Update
We are continuing to investigate this issue.
Posted Nov 24, 2020 - 11:23 UTC
Investigating
We are currently experiencing email delivery issues. We are investigating the problem and are currently working to resolve the issue as soon as possible.

It is taking 10+ minutes for account activation, device confirmation and address confirmation emails to arrive.

Note: If you are experiencing an issue with authorizing a new device, please use a device you have previously approved, if possible to access your account.
Posted Nov 24, 2020 - 10:52 UTC