Intermittent Debit / Credit Card, Apple Pay, Google Pay and ACH Online Banking Purchases Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 08:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2022 - 15:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 08, 2022 - 15:12 UTC
Investigating
We are investigating intermittent issues with debit / credit card, Apple Pay, Google Pay, ACH Online Banking Purchases and PayWithMyBank . Some clients might be experiencing failed transactions temporarily. We are working to resolve the issue and will provide any updates as soon as possible.
Posted Aug 08, 2022 - 14:51 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic, Debit / Credit Cards).