Kraken Futures Maintenance
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 15, 2019 - 14:18 UTC
Investigating
The Kraken Futures platform will be unavailable at 14:30 UTC today as we perform site maintenance.
Posted about 1 month ago. Mar 15, 2019 - 14:07 UTC
This incident affected: Kraken Futures (User Interface, Single Sign-On, REST API, WebSockets API, Cross-Exchange Transfers).