Cosmos (ATOM) Funding Issues
Incident Report for Kraken
Resolved
Cosmos (ATOM) funding delay issue has now been resolved.
Posted 3 months ago. Aug 02, 2019 - 20:20 UTC
Investigating
Cosmos (ATOM) deposits and withdrawals are currently delayed. We are investigating the issue, and will provide any updates as soon as possible.
Posted 3 months ago. Aug 02, 2019 - 19:14 UTC
This incident affected: Digital Currency Funding (Cosmos (ATOM)).