Solana (SOL) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 20:45 UTC
Investigating
Solana (SOL) deposits and withdrawals are currently delayed due to network conditions. We're monitoring and will update when back to normal.
Posted Sep 14, 2021 - 16:30 UTC
This incident affected: Digital Currency Funding (Solana (SOL)).