SIGNET USD Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Mar 11, 2023 - 15:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2023 - 14:19 UTC
Investigating
We're investigating an issue with the SIGNET USD funding gateway. USD deposits and withdrawals via SIGNET are currently delayed. We will provide any updates as soon as possible.
Posted Mar 11, 2023 - 13:59 UTC