Euro (EUR) Funding Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 11 days ago. Aug 13, 2019 - 19:40 UTC
Investigating
Euro (EUR) deposits and withdrawals are currently delayed. We are investigating the issue, and will provide any updates as soon as possible.
Posted 11 days ago. Aug 13, 2019 - 19:31 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits).