Kraken Futures Transfer Delays.
Incident Report for Kraken
Resolved
Funding has been restored. We will continue to monitor the situation closely.
Posted 2 months ago. May 04, 2019 - 04:50 UTC
Investigating
We’re investigating reports of delays for transfers between the kraken.com and Futures platforms. We’ll provide an update as soon as we have further information to provide.
Posted 2 months ago. May 04, 2019 - 04:33 UTC
This incident affected: Kraken Futures (Cross-Exchange Transfers).