Ethereum (ETH) Deposit Delays
Incident Report for Kraken
Resolved
The Ethereum (ETH) deposit delays have now been resolved.
Posted 2 months ago. Jul 12, 2019 - 08:05 UTC
Investigating
We’ve received reports of delays in the processing of Ethereum (ETH) Deposits. Our engineering team is investigating the issue, and we’ll provide an update as soon as possible.
Posted 2 months ago. Jul 12, 2019 - 04:52 UTC
This incident affected: Digital Currency Funding (Ether (ETH)).