Signature USD Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 18:31 UTC
Investigating
We're investigating an issue with the Signature USD Funding Gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Nov 24, 2020 - 14:44 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic, US Dollar (USD) - International).