Funding delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 06:56 UTC
Investigating
We are currently experiencing funding delays processing deposits and withdrawals. Our engineers are aware of the issue and are currently investigating it.

Trading is not impacted.

We will provide an update as soon as possible.
Posted Jul 28, 2020 - 05:27 UTC