Juno (JUNO) Deposits & Withdrawals
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 04:35 UTC
Identified
The Juno (JUNO) Network has come to a halt resulting in blocks and transactions not processing. Deposits and withdrawals on Kraken will be processed once the network is active and the network is deemed safe to transact on.

Status updates on the network may be found here https://twitter.com/junonetwork

Activity on the chain may be tracked here https://www.mintscan.io/juno
Posted Jul 28, 2022 - 08:45 UTC
This incident affected: Digital Currency Funding (Juno (JUNO)).