Cosmos (ATOM) Funding
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 12 days ago. Oct 06, 2019 - 14:32 UTC
Investigating
Cosmos (ATOM) deposits and withdrawals are currently delayed. We are investigating the issue, and will provide any updates as soon as possible.
Posted 12 days ago. Oct 06, 2019 - 09:15 UTC
This incident affected: Digital Currency Funding (Cosmos (ATOM)).