USD Domestic Funding Issue
Incident Report for Kraken
Resolved
Domestic USD funding has now been restored.
Posted 23 days ago. Aug 28, 2019 - 05:29 UTC
Identified
We've identified an issue in the processing of domestic USD deposits and withdrawals. Our engineering team is working to resolve the issue, and we'll provide an update as soon as possible.
Posted 23 days ago. Aug 27, 2019 - 23:16 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic).