CAD Funding Issues
Incident Report for Kraken
Resolved
Canadian Dollar (CAD) Funding has been restored.
Posted 2 months ago. Jul 10, 2019 - 19:17 UTC
Investigating
We are currently experiencing issues with CAD funding via POSconnect. This affects CAD EFT withdrawals as well as In-Person Payments. We are working to resolve the issue and will update as soon as we have further information.
Posted 2 months ago. Jul 10, 2019 - 17:11 UTC
This incident affected: Fiat Currency Funding (Canadian Dollar (CAD) - Domestic).