Bank Frick Deposits/Withdrawals Unavailable
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 13:01 UTC
Investigating
Deposits and withdrawals via Bank Frick are unavailable at this time while we investigate an issue. We will provide any updates as soon as possible.
Posted Oct 13, 2021 - 14:56 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits, US Dollar (USD) - International, Canadian Dollar (CAD) - International, Swiss Franc (CHF) - Domestic, Swiss Franc (CHF) - International, Pound Sterling (GBP) - International).