Intermittent Issues Impacting Cryptowat.ch & Trade.kraken.com
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 19:30 UTC
Identified
The issue has been identified as an AWS power outage in a few of their AWS regions impacting Kraken services such as Cryptowat.ch & Trade.kraken.com. As of right now Clients may experience slow page loads and trading data may reflect stale price information. AWS has restored power to their regions which impact Kraken and we're now slowly coming back online rebooting internal services. We will continue to provide updates as necessary.
Posted Jul 28, 2022 - 17:48 UTC
This incident affected: Website.