Deposits are now fully caught up and are being processed in real time. All systems are operating normally. Thank you for your patience during the maintenance period.
Posted 7 days ago. Mar 24, 2025 - 21:41 UTC
Update
Deposits are now being processed. We expect to be fully caught up with all current transactions within the next hour. Thank you for your patience.
Posted 7 days ago. Mar 24, 2025 - 21:08 UTC
Update
Withdrawals are now processing in real time. Maintenance is still in progress, and deposits are expected to resume within the hour. We appreciate your continued patience and support.
Posted 7 days ago. Mar 24, 2025 - 20:39 UTC
Update
Maintenance is still ongoing. Withdrawals have resumed and are actively being processed — we expect to be caught up with all current requests within the next hour. Deposits are expected to resume in approximately one hour as well. Thank you for your continued patience.
Posted 7 days ago. Mar 24, 2025 - 19:58 UTC
Update
Withdrawals have resumed; however, due to a significant backlog, processing times may be delayed. We are actively working through requests and expect to complete processing over the next few hours. We appreciate your patience.
Posted 7 days ago. Mar 24, 2025 - 19:30 UTC
Update
The scheduled maintenance for Litecoin (LTC) funding gateway continues to be underway and has been extended for 1 hour. We will continue to provide updates as necessary.
Posted 7 days ago. Mar 24, 2025 - 18:52 UTC
Update
The scheduled maintenance for Litecoin (LTC) funding gateway continues to be underway and has been extended for 1 hour. We will continue to provide updates as necessary.
Posted 7 days ago. Mar 24, 2025 - 16:52 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 7 days ago. Mar 24, 2025 - 14:00 UTC
Scheduled
The Litecoin (LTC) funding gateway will be undergoing maintenance from 14:00 UTC, March 24 for approximately 4 hours. Deposits and withdrawals will be unavailable - transfers made during this time will be processed shortly after the maintenance is complete. We will provide updates as necessary.
Posted 10 days ago. Mar 21, 2025 - 16:26 UTC
This scheduled maintenance affected: Digital Currency Funding (Litecoin (LTC)).