Euro Deposit & Withdrawal Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2019 - 11:33 UTC
Investigating
We've received reports of delays in the processing of Euro (EUR) deposits and withdrawals. Our engineering team is investigating the issue, and we'll provide an update as soon as possible.
Posted about 1 month ago. Jul 17, 2019 - 01:03 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits).