Krak Card - Digital Wallet Provisioning Unavailable

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 20, 2026 - 11:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 10:48 UTC

Investigating

We are aware of an issue affecting the ability to add Krak Card to Apple Wallet and Google Wallet. We have identified that this is caused by a disruption with an upstream service provider and are actively monitoring for resolution.

Card transactions and 3D Secure (3DS) authentication are not affected and continue to operate normally.

We will provide a further update once we have more information.
Posted May 20, 2026 - 10:02 UTC