Dash (DASH) Funding issues

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted 2 years ago. May 23, 2023 - 07:49 UTC

Identified

Dash chain has halted and no new blocks are being produced since the v19 upgrade. Deposits and withdrawals will not be processed until this issue is resolved. We will provide updates as soon as information is available.
Posted 2 years ago. May 22, 2023 - 13:30 UTC
This incident affected: Digital Currency Funding (Dash (DASH)).