CustomersBank Wires Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 04, 2023 - 03:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2023 - 18:50 UTC

Identified

We're investigating an issue with CustomersBank Wires delays. Withdrawals may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Nov 02, 2023 - 20:57 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).