Issues with EUR withdrawals

Incident Report for Kraken

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2026 - 18:32 UTC

Investigating

Some clients have experienced failed EUR withdrawals. We are investigating with our payment provider and working to restore normal service. We will share an update as soon as more information is available.
Posted Jul 15, 2026 - 17:35 UTC
This incident affects: Payment Methods (Euro (EUR) - Instant, Euro (EUR) - SEPA).