[Scheduled] Website offline for maintenance
Incident Report for Kraken
Resolved
Website operations have now resumed. Thank you!
Posted Dec 15, 2017 - 22:54 UTC
Monitoring
At 2:30PM Pacific Time, the website will be offline for maintenance for about 20 minutes. We appreciate your patience and will update you when we're back online.
Posted Dec 15, 2017 - 22:28 UTC