Funding issues when placing trading orders or instant purchases
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 17:24 UTC
Investigating
We are currently investigating reports that some clients may see erroneous insufficient funds balance information when trading or using instant buy.
Posted Aug 02, 2022 - 15:04 UTC
This incident affected: Website.