Connectivity Issues - Kraken US Futures

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 15:55 UTC

Investigating

We are aware of an ongoing outage at the external provider, which is impacting US Futures trading via NinjaTrader. As a result, clients may be unable to place or execute US Futures orders at this time.

We are monitoring the situation closely. We will provide updates as soon as further information becomes available.
Posted Nov 28, 2025 - 13:00 UTC