Ethereum Transaction Delays
Incident Report for Kraken
Resolved
Ethereum deposit times have returned to normal.
Posted Aug 12, 2018 - 08:28 UTC
Investigating
We are currently experiencing delays with deposits and withdrawals for Ethereum. Our development team is investigating the issue.
Posted Aug 12, 2018 - 02:43 UTC
This incident affected: Digital Currency Funding (Ethereum (ETH)).