iDEAL Funding Delays

Incident Report for Kraken

Monitoring

We’ve determined that the impact ended at around June 7, 2025, at 22:15 UTC. Any deposits that failed during this period will be automatically returned to the originating bank account. We are actively monitoring the situation and continuing to work closely with our funding provider to determine the root cause.
Posted Jun 08, 2025 - 09:30 UTC

Investigating

We're investigating an issue with the iDEAL funding gateway. Some deposits may be delayed at this time. All other funding methods are operating normally. We are actively working with our funding provider to resolve the issue and will keep you updated.
Posted Jun 07, 2025 - 15:03 UTC
This incident affects: Payment Methods (Euro (EUR) - Instant).