Withdrawal addresses not appearing
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 12:08 UTC
Identified
We have identified the cause of the issue and are working to restore normal service. We will update as soon as we can, thank you for your patience.
Posted Jul 23, 2024 - 08:02 UTC
Update
We are aware that some users are experiencing delays with withdrawals. We are investigating the issue and will update as soon as possible.
Posted Jul 23, 2024 - 07:42 UTC
Investigating
We are currently investigating this issue.
Posted Jul 23, 2024 - 02:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2024 - 01:02 UTC
Investigating
Withdrawal addresses not appearing. We are currently investigating the issue.
Posted Jul 23, 2024 - 00:30 UTC
This incident affected: Website and Mobile Applications.