Document upload widget on www.kraken.com not working

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 13:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2026 - 12:52 UTC

Investigating

An issue in the onboarding flow on www.kraken.com is currently preventing document uploads. Other platforms remain unaffected. We are currently working to fix and will provide updates soon.
Posted Feb 17, 2026 - 12:13 UTC
This incident affected: Website, Kraken App, and Kraken Pro App.