Incorrect All-Time High Price Alerts

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 17:41 UTC

Identified

We have identified the cause of an issue where clients were receiving incorrect all-time high price alerts. We are actively working to disable the affected alerts and prevent any further incorrect notifications from being delivered. Trading and core platform functionality are not impacted.

We will continue to provide updates as remediation progresses.
Posted Dec 29, 2025 - 16:54 UTC
This incident affected: Website.